How to Create, Test and Remediate Spreadsheets for Section 508 Conformance Using Microsoft Excel
# Table of Contents

Background ..................................................................................................................................... 3

How to Read This Document .......................................................................................................... 3

AED COP Excel Checklist ............................................................................................................. 4
  
  Document Formatting ....................................................................................................................... 4
  
  Text Formatting .......................................................................................................................... 4
  
  Object Formatting ....................................................................................................................... 4
  
  Color Formatting ......................................................................................................................... 5
  
  Miscellaneous ............................................................................................................................. 5

Microsoft Excel 2016 | Basic Authoring and Testing Guide .......................................................... 6

Document Formatting ..................................................................................................................... 6

  1. Is the filename descriptive and is the file in .xlsx format? .................................................. 6

Text Formatting .............................................................................................................................. 7

  2. Are built-in features used to organize content? ................................................................... 7
  
  3. Are link names descriptive? ................................................................................................. 7

Object Formatting ........................................................................................................................... 9

  4. Is vital information in headers, footers, and watermarks duplicated in the worksheet? ...... 9
  
  5. Did you use built-in features to create data tables? ........................................................... 10
  
  6. Do images and other objects have alternative text ............................................................. 12

Color Formatting ........................................................................................................................... 14

  7. Are colors and other visual characteristics that convey information (such as size, shape, and location) also described in text? ................................................................................. 14
  
  8. Is the contrast ratio between text and background sufficient? ........................................... 15

Miscellaneous ............................................................................................................................... 18

  9. Are descriptions of embedded audio, video and multimedia files accurate? ..................... 18
  
  10. Did you exclude flashing objects? ....................................................................................... 18

Index of Figures ............................................................................................................................ 19

Index of Tables .............................................................................................................................. 19
**Background**

The purpose of this document is to assist individuals in creating, testing, and remediating Microsoft Excel Spreadsheets, for Section 508 conformance. The guidance provided is based on the Section 508 Baseline Test Guide for Excel files, and the Section 508 Microsoft Excel 2016 Checklist authored by the Accessible Electronic Document Community of Practice (AED COP). For more information on the AED COP, to download the latest AED COP guidance, and to gain access to a detailed test process, visit the [Federal Section 508 website](https://www.section508.gov/).

**How to Read This Document**

This document is comprised of two sections:

1. The AED COP Microsoft Excel 2016 Checklist.
2. Instructions on how to remediate Excel files for Section 508 compliance.

For more information on how to remediate MS Excel (.xlsx) documents or to request training, please [contact your agency Section 508 Coordinator](mailto:Section508-OCIO@usda.gov) or email **Section508-OCIO@usda.gov**.
**AED COP Excel Checklist**

When creating an accessible spreadsheet, or when reviewing an Excel file for Section 508 conformance, the following conditions must be considered. The response to each criterion should be **Yes** or **Not Applicable** to be considered accessible. If **No** is selected, the issue must be resolved to be considered accessible.

For ease of use, Microsoft Excel’s Accessibility Checker is located on Microsoft’s main menu under **File > Info > Check for Issues > Check Accessibility**.

**Note:** Due to the human-centric nature of accessibility and Section 508 conformance, content creators must ensure individuals with disabilities are able to request additional formats and corrections that may not be detected using automated tools, i.e., improper use of color coding.

### Document Formatting

<table>
<thead>
<tr>
<th>A. Save as an Excel Workbook (.xlsx) with a descriptive filename</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>The filename is descriptive and identifies the document or its purpose.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The file type is an Excel 2016 Workbook (.xlsx).</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Text Formatting

<table>
<thead>
<tr>
<th>C. Create unambiguous names for links</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link names are unambiguous within context and describe the destination, function, or purpose.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Object Formatting

<table>
<thead>
<tr>
<th>D. Duplicate vital information in Headers, Footers, and “Watermarks”</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vital information is duplicated at or near the start of the related information.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>E. Use built-in features to create data tables</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data tables are not pictures.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data tables do not have merged/split cells.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data tables do not have more than one header row/column.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>F. Create accessible images and other objects</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>There is descriptive alternate text, descriptive text in surrounding text, or in an appendix.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Color Formatting

<table>
<thead>
<tr>
<th>G. Use color (and other sensory characteristics) plus text to convey meaning</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text duplicates the meaning of the color or other sensory characteristics.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H. Create the required color contrast</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>The color contrast ratio passes (WCAG Level AA).</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Miscellaneous

<table>
<thead>
<tr>
<th>I. Create accessible embedded files</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>For audio-only, the transcript is accurate and complete.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>For video-only, the text description is accurate and complete.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>For multimedia, the synchronized captions and audio description are accurate and complete.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>J. Avoid forms in MS Excel 2016</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forms are not enabled.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>K. Exclude flashing objects</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flashing objects are excluded.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>L. Alternative accessible version</th>
<th>Yes</th>
<th>No</th>
<th>NA</th>
</tr>
</thead>
<tbody>
<tr>
<td>The information is equivalent and up to date with the primary document.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Microsoft Excel 2016 | Basic Authoring and Testing Guide

This section provides detailed instructions on creating, remediating, and testing MS Excel files (.xlsx) for accessibility.

**Document Formatting**

1. *Is the filename descriptive and is the file in .xlsx format?*

**How to Test**

**Instruction:** Look at the filename in Windows Explorer or the title bar in MS Excel. An example of a descriptive filename is “FundingBudget.xlsx.” The file must be in the “*.xlsx” format for accessibility testing to be possible.

**NOTE:** If the document extension is not displayed, open your documents folder in Windows Explorer, select “View”>check “File name extensions.”

**Figure 1:** The Save As dialog window

![Save As Dialog](image)

Test A: Is the file name descriptive and does it identify the document or its purpose? If not, the document fails this test.

Test B: Is the file in “Excel Workbook (.xlsx)” format? If not, the document fails this test.

**How to author for accessibility**

A descriptive file name identifying the document, or its purpose, helps everyone (including people with disabilities) locate, open, and switch between documents. In addition, the document must be in a “.xlsx” format because these authoring and testing instructions will only work if the file is in the “.xlsx” file format.

- Select “File tab>Save As”
- Save as type: “Excel Workbook (*.xlsx)” with a descriptive filename.

Content written and managed by the AED COP | Last Updated: August 2021
Text Formatting

2. Are built-in features used to organize content?

How to test

Test A: Does each sheet have a visual and/or logical reading order, left to right then top to bottom? If not, it fails this test.

Test B: Can the sheet be navigated using the up, down, right or left arrow keys, and does it match the visual/logical reading order? If not, it fails this test.

How to author for accessibility

To create a worksheet with logical reading order content:

• Start all worksheets in cell A1
• Do not span content over multiple rows or columns.

Figure 2: Example of Excel Worksheet with logical reading order

3. Are link names descriptive?

How to test

Instruction: Find hyperlinks within a worksheet

Test: Do links have meaningful names that describe their destination, function, and/or purpose OR are these determinable within context? If not, the document fails this test.

Uniquely Named Link:
www.section508.gov

Link Determinable within context:
Get My Section 508 Questions Answered

An unclear link name with no context:
click here
How to author for accessibility

Assistive technology users rely on meaningful names to determine the destination, function, or purpose of links. For example, multiple “click here” links are confusing to assistive technology users because the name for each link is the same, while the destinations may be different.

**Figure 3: Insert Hyperlink configuration window**

![Insert Hyperlink configuration window](image)

Naming and creating links:

- To edit the name of a link, select the cell containing the hyperlink. Edit the text in the Formula Bar.
- To create a hyperlink, select the cell for the hyperlink and either use the Hyperlink button on the "Insert" ribbon menu or "Ctrl+K" to open the Insert Hyperlink configuration window. Specify the Text to display and the Address for the link and its destination.
Object Formatting

4. Is vital information in headers, footers, and watermarks duplicated in the worksheet?

How to test

**Instruction:** Look for vital information in headers, footers, and watermarks (e.g. Respond by X date, CONFIDENTIAL, or Do Not Distribute). **Note:** Watermarks in Excel are floating objects, and cannot be made accessible.

**Test:** Is the vital information duplicated in the first cell of the worksheet? If not, the document fails this test.

**Figure 4:** Example of vital information repeated in cell A1 of the worksheet

How to author for accessibility

Assistive technology does not automatically read information in headers, footers, and watermarks, so you need to duplicate any vital information in cell A1.
5. Did you use built-in features to create data tables?

How to test

Instruction 1: Select a table (“Home>Editing>Find & Select>Go To”). Select any table listed in the “Go To” options window. Note: Images of tables will never be listed in the “Go To” options window.

Test A: Does a “Table Name” display under the “Table Tools>Design>Properties” group? If not, the document fails this test.

Figure 5: Table Properties group displaying Table Name

Instruction 2: Place your cursor on the first row and/or column of a table cell and see if the worksheet has identified the header row and/or column.

Test B: Are “Header Row” and/or “First Column” in the “Table Style Options” group checked? If not, the document fails this test.
Instruction 3: Select a table. If the Ribbon shows “Picture Tools” tab, instead of the “Table Tools” tab, then the table is an image.

Test C: Is the worksheet free of pictures of tables? If not, the document fails this test.

Figure 7: Image of data table showing “Picture Tools>Format” tab when selected

How to author for accessibility

Assistive technology users need to be able to identify column headers in data tables to understand the association between table cells and their respective headers.
To create an accessible data table you select “Insert>Table.”

1. In the create table pane, choose the range of cells for your data table.
2. Check the “My table has headers” checkbox in the create table pane.
3. Choose any cell and name your table “Table Tools>Design>Table Name.”
4. Choose the first cell in the header column and/or row, and update the column and/or row headings with descriptive names.

**How to test**

**Figure 8:** Image of data table showing “Picture Tools>Format” tab when selected

6. **Do images and other objects have alternative text**

**How to test**

**Instruction 1:** Examine cells surrounding a non-text element for text describing the object or its purpose/meaning.

**Test A:** Does the image/object/shape/chart or other non-text element have descriptive text or is there an appendix for all non-text elements? If not, the document fails this test.

**How to author for accessibility**

In Excel images, objects, shapes, charts and other non-text elements cannot be anchored/embedded in a cell. Screen reader users cannot access the alt-text of floating elements. Therefore, you must add descriptive text to images and other objects by adding
information in a cell near the object or list the non-text elements and their descriptions in a separate appendix.
Color Formatting

7. Are colors and other visual characteristics that convey information (such as size, shape, and location) also described in text?

How to test

Using only color or other visual characteristics to convey meaning will not provide comparable access to people who are blind, have low vision, or are colorblind.

Instruction: Find where you have used color and/or other visual characteristics to convey meaning such as green, yellow, red, etc.

Test: Is there text that conveys the meaning of the color or other visual characteristics? If not, the document fails this test.

How to author for accessibility

The following layout tables describe the progress for three projects using colors to symbolize the current project status. Adding text in addition to the color provides comparable information to users of assistive technology and people who are colorblind.

Use text to duplicate the meaning of the color or visual characteristics (such as size, shape, and location).

Table 1: Examples of a project status table using only color and color with text

<table>
<thead>
<tr>
<th>Project</th>
<th>Status</th>
<th>Project</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project A</td>
<td>On Time</td>
<td>Project A</td>
<td>On Time</td>
</tr>
<tr>
<td>Project B</td>
<td>At Risk</td>
<td>Project B</td>
<td>At Risk</td>
</tr>
<tr>
<td>Project C</td>
<td>Late</td>
<td>Project C</td>
<td>Late</td>
</tr>
</tbody>
</table>
8. **Is the contrast ratio between text and background sufficient?**

   NOTE: If the document text is black on white background (or close to it), you do not need to perform this test. This test requires the [Colour Contrast Analyzer](#) (an external application).

**How to test**

Execute the *Colour Contrast Analyzer*. Select “Download” (the application can be executed without downloading it onto your computer). Open the *Colour Contrast Analyzer*. Drag the “Foreground eyedropper” icon over a sample of your text or image of text. Drag the “Background eyedropper” icon over a sample of your background color.

**Test:** Have you formatted with the correct color contrast ratio? If not, the document fails this test.

**Figure 9:** Examples of pass and fail results with the *Colour Contrast Analyzer*
How to author for accessibility

People who are colorblind or have low vision will have comparable access if there is sufficient contrast between the text and the background. The contrast standards are:

Table 2: Table with contrast ratios for types and sizes of text

<table>
<thead>
<tr>
<th>Type or Size of Text</th>
<th>Contrast Ratio</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard text (12 pt regular)</td>
<td>4.5:1</td>
</tr>
<tr>
<td><strong>Large Text</strong> (14 pt bold or 18 pt regular)</td>
<td>3:1</td>
</tr>
<tr>
<td>Incidental text, text overlaid on images, and logotypes</td>
<td>Excluded from requirement</td>
</tr>
</tbody>
</table>

Create content with text or images of text that use color or shading with sufficient color contrast. If the contrast ratio does not pass, then adjust your foreground or background until it does pass.

Table 3: Examples of good and insufficient color contrast ratios

<table>
<thead>
<tr>
<th>Good Color Contrast</th>
<th>Insufficient Color Contrast</th>
</tr>
</thead>
<tbody>
<tr>
<td>White text on black background ratio 21:0:1</td>
<td>Dark gray text on black background ratio 3.0:1</td>
</tr>
<tr>
<td>Dark green text on yellow background ratio 7.6:1</td>
<td>Orange text on yellow background ratio: 2.1:1</td>
</tr>
<tr>
<td>Light blue text on dark blue background ratio: 10.5:1</td>
<td>Red text on dark blue background ratio: 1.1:1</td>
</tr>
<tr>
<td>white text on red background ratio: 6.5:1</td>
<td>Dark green text on red background ratio: 1.3:1</td>
</tr>
</tbody>
</table>
### Miscellaneous

#### 9. Are descriptions of embedded audio, video and multimedia files accurate?

**How to test**

*NOTE:* If the document does not contain audio, video, or multimedia files, you do not need to perform this test.

**Instruction:** Activate the audio-only, video-only, or multimedia file.

**Test A:** Is there an accurate and complete text transcript for multimedia files, text description for audio files, and synchronized caption and/or audio description for video files? If not, the document fails this test.

**How to author for accessibility**

If you embed an audio-only, video-only, or multimedia file that contains meaningful information into your MS Excel Workbook, you must also provide additional information so that individuals with disabilities have comparable access to the information.

- Audio-only
  - Accurate and complete transcript
- Video-only
  - Accurate and complete text description
- Multimedia (audio and video)
  - Accurate and complete synchronized captions and audio descriptions

#### 10. Did you exclude flashing objects?

**How to test**

**Test:** Is the document free of all flashing objects? If not, the document fails this test.

**How to author for accessibility**

Create your content without using flashing objects. Flashing objects can cause seizures and should never be used.
Index of Figures
Figure 1: The Save As dialog window ................................................................. 6
Figure 2: Example of Excel Worksheet with logical reading order .................... 7
Figure 3: Insert Hyperlink configuration window .................................................. 8
Figure 4: Example of vital information repeated in cell A1 of the worksheet .......... 9
Figure 5: Table Properties group displaying Table Name .................................... 10
Figure 6: Header Row and First Column checked in the Table Style Options group .... 11
Figure 7: Image of data table showing “Picture Tools>Format” tab when selected ...... 11
Figure 8: Image of data table showing “Picture Tools>Format” tab when selected ...... 12
Figure 9: Examples of pass and fail results with the Colour Contrast Analyser .......... 15

Index of Tables
Table 1: Examples of a project status table using only color and color with text .......... 14
Table 2: Table with contrast ratios for types and sizes of text .................................. 17
Table 3: Examples of good and insufficient color contrast ratios ............................ 17